Volkswagen Passat Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
983 Posts
Discussion Starter #1
I’ve been getting this stupid code forever now, I’ve replaced all 4 sensors, I’ve read the cats may need to be replaced but I’m not going to spend the money for OEM units. Has anyone replaced the cat with flea bay units? What else could trigger this darn code?


Sent from my iPad using Tapatalk
 

·
in dire need of an organic chemistry lesson
Joined
·
2,294 Posts
If you have already replaced the O2 sensors then the next step is to replace the cat. Depending on the age of your car you may go with the after market one off eBay but stay away from suspeciously low priced ones.
 

·
Registered
Joined
·
983 Posts
Discussion Starter #7
It doesn’t I’ll scan it next time with vcds


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
26,315 Posts
The code is for bank1, but I would add O2 spacers to the rear sensors on both sides. Since you don't have rust down there, I doubt a bad flex joint is to blame. The O2 spacers worked on my V6.
 

·
Registered
Joined
·
3 Posts
I’ve been getting this stupid code forever now, I’ve replaced all 4 sensors, I’ve read the cats may need to be replaced but I’m not going to spend the money for OEM units. Has anyone replaced the cat with flea bay units? What else could trigger this darn code?


Sent from my iPad using Tapatalk
I replaced my cats with mid priced ones from rockauto. They are great and restored power I didn't realize I had lost. I did the work myself but regretted it. The bolts at the headers are against the fire wall and a real trick to get at. Plus the length and shape of the pipes make them difficult to thread into the car without a lift. Working from ramps I had to remove transmission mounts and curse German engineering to get the new cats installed
 

·
Registered
Joined
·
26,315 Posts
No visual in Texas and the 2nd set of sensors are not visible under the hood. They are behind the 2nd set of cats, just past the tail of the trans.
 

·
Registered
Joined
·
983 Posts
Discussion Starter #13
The code is for bank1, but I would add O2 spacers to the rear sensors on both sides. Since you don't have rust down there, I doubt a bad flex joint is to blame. The O2 spacers worked on my V6.
Would any spacers from Ebay work or would you recommend something very specific?

ie:

 

·
Registered
Joined
·
25 Posts
I’ve been getting this stupid code forever now, I’ve replaced all 4 sensors, I’ve read the cats may need to be replaced but I’m not going to spend the money for OEM units. Has anyone replaced the cat with flea bay units? What else could trigger this darn code?


Sent from my iPad using Tapatalk
I replaced the whole exhaust system with parts purchased from JC Whitney - all fit and worked well.
If you have dual exhausts, be sure to hook up both sets of sensors to the correct side... I originally crossed one set (I forget front or rear) and it gave me bad codes, till I fixed that - fine ever since.
(It was reading one thing before the CAT and the reading after the CAT didn't make sense to the computer, compared to the before reading. )
 

·
Registered
Joined
·
25 Posts
You might be able to clear the code with a spacer for the O2 sensor, but that is probably a temporary fix

Officially:
P0421 VOLKSWAGEN Possible Causes
Warm Up Three Way Catalytic converter deterioration or malfunction
Exhaust system leaks
Loose front or rear HO2Ss
Faulty front heater O2 sensor
O2 sensors harness is open or shorted
O2 sensors poor electrical connection

Read more: https://www.autocodes.com/p0421_volkswagen.html
 

·
Registered
Joined
·
26,315 Posts
Would any spacers from Ebay work or would you recommend something very specific?

ie:

They should work if they are deep enough. The Autozone ones (actually sparkplug anti-foulers) require drilling slightly larger. The Ebay ones I bought later did not.
 

·
Registered
Joined
·
26,315 Posts
My spacers worked for years without issue. The previous CEL came on in cooler weather and always went away when warm. I am now running a spacer on my 1.8T swap as it had bad misfires and a bad turbo, leading to a bad cat. I also have a spacer on my wife's Golf as it had a cat code, but was out of the extended emissions warranty.
 

·
Registered
Joined
·
983 Posts
Discussion Starter #19
I might have spoken too soon, right after posting “no more cel”, for a week at least , I get a P0141 code now.....gremlins at work


Sent from my iPhone using Tapatalk
 
1 - 20 of 24 Posts
Top