Volkswagen Passat Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
581 Posts
Discussion Starter · #1 ·
People, I gonna need a little help here. :icon_eek:

You have been much more prestative (as strange as it seems) than the other Passat mechanics here in my country. If you guys hadn´t helped I´d probably never be able to get my trunk´s light working, lol. :cool:

Since I bought this car (B5 1.8T AEB 98/99) I´ve noticed that the Airbag light has this strange behaviour: every time I start the ignition (just the electronic stuff without running the engine), the airbag light stands lit until I start the motor. Once I get the motor running, the airbag light disappears. I always considered that very weird but never worried too much about it, whatever.

Now things seem to be a little more complicated. Even when the motor is running, everytime I let the RPM goes down the airbag light lits briefly and then disappear again when RPM gets back to its normal value (~1.000 RPM).

Actually it seems to me that the airbag light is working as a "RPM Ligth" that lits everytime the motor is just about to die.

Note: to die is an expression we use here in Brazil referring to that situations on which we accidentaly release the clutch faster than we should resulting in the engine lugging and the car bucking (manual shift).

Has any of you ever passed through something like that? What´s the best and the worst case scenario? AirBag module replacement? :nervous:

Thank you all for you help and sorry for any mistakes.

Best Regards,
Vitor.
 

·
Banned
Joined
·
8,975 Posts
It sounds like either your airbag wiring is faulty and it's not allowing enough voltage to reach the airbag, or your alternator is faulty and it's not supplying enough voltage to the car.
 

·
Registered
Joined
·
11,873 Posts
Sounds like a faulty alternator, I had that problem once in a GM vehicle and the airbag light came on then the abs and so on.
 

·
Registered
Joined
·
581 Posts
Discussion Starter · #6 ·
All right, thank you all for the suggestions. I´ll go check the alternator asap and post the feedback later. :thumbup:

Today I tryed to tape a brief video of what happens exactly with the dash lights (specially the airbag light) to give you guys a better idea of the problem. Unfortunately, I could not reproduce the symptons, the airbag light simply wouldn´t lit even if I let the RPM fall.

VIDEO:
http://www.youtube.com/watch?v=x7gg6G2rB3U

Wonder if it proves something: while the car is cold, whith just a few moments of motor work, no airbag light at all. After around 30min of work, the airbag light starts to follow the RPM exactly as I described before. RPM Down, light turns on. RPM above 1.000, no light at all.
Do these symptons point to the alternator as well?

How is the airbag light behaviour on your car? Note that before this RPM thing, in my car, the Airbag light stands lit until I start the motor. Once I get the motor running, the airbag light disappears. Is this right?

Thanks!
 
1 - 6 of 6 Posts
Top