Volkswagen Passat Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
So, I recently bought a beautiful 2003 GLX V6 Wagon FWD. It's in pretty amazing condition and has been fantastic to me. Unfortunately it had a slow coolant leak.

After some reading here I found that it was possibly the CTS and went to buy one. I didn't realize I should have bought a new CTS clip and when I got home has a super hard time getting the clip on to hold the CTS down. It was like I had to push SUPER hard down on the CTS while pushing the clip on. I finally got it on after about 20 tries. My hand was pretty messed up. I went to drive to dinner and BLASH, the sensor popped out. Either I still hadn't gotten it on right or the clip was too old and weak to hold the CTS in place. Unfortunately, I drove a few miles before realizing what the sound actually was. I pulled over and had the car towed, but I'm afraid I was too late. The check engine light came on right before I pulled over, but no other warnings came on.

The clip fell into the engine abyss and I couldn't get one locally. Next weekend I am going to try to put a new clip on, but I am really worried about the process. I am thinking about removing the Throttle Body Tube, as I just don't think I can be 100% sure the clip is on right without the space.

Removing the Throttle Body Tube looks like a lot of fun.

Anyway, I have to sit on my hands for a week hoping that when I get the CTS back in, I still have a functioning vehicle. Should have just let it leak.

You guys think my engine is toast?
 
1 - 1 of 1 Posts
Top