Volkswagen Passat Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter #1 (Edited)
Hi,
I've been having issues with my 99 aeb for about a year now. Once it gets about 70 degrees out I had misfires/bogging down/ erratice idle. The problem was that there was NO CELs. It could usually be fixed by turning the car off and starting it right up again. I recently bought a used ECU and swapped them out. I now have some codes! The guy at autozone said the last two were "pending".

P1565 throttle position lower limit not obtained.
I have cleaned the throttle body and put in a new gasket a few months ago.

P1613 MIL Call-up Circ Open/Short to B+
I think this is because the new ECU is from an auto and I have a manual?

P0134 Heated oxygen sensor no activity detected
how could this be pending?

P0103 Mass air flow sensor circuit high input
I also cleaned the maf when these issues started a while back.
I also tried unplugging it and starting the car but it wouldn't start with MAF unplugged.

Anyone have any clues on where to start? I don't want to start throwing money at this vehicle with 190k on it. Also I don't have a VAG-COM.
Thanks for any tips.
 

·
Registered
Joined
·
4,022 Posts
Do you still have the misfire, etc. issues, or were they resolved w/ the replacement ECU? Have you cleared the codes to see if they come back? The AEB ECU can hold codes from the donor vehicle, so if you didn't have them cleared after installing the ECU, there's a chance that they are "left overs"...
 

·
Registered
Joined
·
173 Posts
Discussion Starter #3
I don't have a VAG so I have no way of clearing codes. I have had less misfires but it seems like the problem is not completely resolved. When I first started the car there after swapping ECUs there were no codes. I turned it off and started it again. Then the codes showed up.
 

·
Registered
Joined
·
173 Posts
Discussion Starter #4
I got the codes cleared and the only one that comes up now is p1613. I don't know for sure if the new ecu was from an auto or stick. Anyone have any info on this code? My idle is also crap now but I'm sure it just needs a tb adaption.
 

·
Registered
Joined
·
173 Posts
Discussion Starter #5
After reprogramming the ecu for to a manual, replacing the 02 sensor and the MAF, my car seems to be back to normal. My original ECU did not pick up the 02 fault and it took my indy mech a long time to nail down the faulty MAF. There were never any codes for any MAF related issues. This problem was very intermittent. Hope this might help someone else out there with similar issues.
 
1 - 5 of 5 Posts
Top