Volkswagen Passat Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
388 Posts
Discussion Starter #1
My wife broke the wiper switch off at the stalk on our 2003 Passat 1.8t. Evidently she was very angry that it was raining.

So I went and got a new switch from the junkyard (since its the "multi function" switch with the switch on the side its $250 new or $10 from the junk yard), got the airbag off (practiced at the junkyard, fortunately the one I found had the keys in it, :thumbup:).

Put everything back together and BOOM, wipers work fine but the turn signals don't automatically click off after a turn. Not a huge deal but I decide to take it all apart again, this time the airbag was more irritating as I overthought it and the bracket the airbag snaps into took a little beating trying to get the spring off the mounting tab. Basically I broke the small metal ground behind the bracket, I actually electrical taped it together and all was well except the turn signals still didn't auto turn off.

I went back to the junkyard to get a new bracket taking my time to NOT break that wire, $6 later, good to to. Got everything replaced again in the car, no the HORN will not go off unless I fiddle with the airbag. I know that metal ground thing behind the airbag bracket has to do with the horn but its on or I have to pull the fuse.

any ideas other than another bracket?
 

·
Registered
Joined
·
776 Posts
Turn signals:
Fault is most likely with the switch itself. Probably just a coincidental failure.
The only other thing that it could be is that the (rather large) 'finger' on the back of the steering wheel was broken off. You didn't drop the wheel while it was off, did you?

Horn:
Assuming that you actually connected both horn wires to the impact plate (the airbag mounting bracket), I'd say "impact plate is faulty." At the spring mounts, there are also plastic bushings (to electrically isolate it from the wheel itself.) If one is missing, it's shorted to ground, and the horn is permanently on.
 

·
Registered
Joined
·
388 Posts
Discussion Starter #3
Thanks cuppie, I fixed the turn signals, there is that tab looking thing on the clock spring I didn't have aligned properly so that is fixed, so turn signals and wipers are working find.

The horn is still the only issue, currently the fuse is pulled. When I put the airbag bracket back on (with the silver ground all attached this time without electrical tape :lol:, and without the airbag installed the horn would go off but pressing lightly on the top right of the bracket it would usually go off fine. but after reinstalling the airbag it goes off, if I fiddle with that same area, it will go off but sometimes just come back on. So obviously that area is the issue.

I'm guess that area is somehow shorting itself, those bushings and springs are all in place, I guess I might need another bracket?
 

·
Registered
Joined
·
776 Posts
Sounds like, yeah. So long as there isn't any bare wire contacting places that it shouldn't (in the wheel), I'd say that the fault is in the impact plate. Or, just get another wheel.

Turn signals:
That, I mis-remembered (steering wheel vs. clockspring for tripping the signal release.) But, good that you got that part figured out. :thumbup:
 
1 - 4 of 4 Posts
Top