Volkswagen Passat Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter · #1 ·
Maybe someone can shed some light on what i've done. In an attempt to see if my mass air flow sensor was faulty I swapped it for my dads. I have a 2002 130 TDI with 96K and my dads is a 2005 (same shape) 130 TDI with 7K miles. After about a day my dads car started to say Emissions Workshop and now has a steady yellow exhaust emissions light. We have swappwed the sensors back and even disconnected the battery for 15mins and the faulty light persists. My car however never displayed any faults with either sensor. Can someone help as I don't fancy paying VW and arm and a leg to fix my dads if its something stupid I have done.

Thx
 

·
Registered
Joined
·
212 Posts
Just swap the sensor back. Take it to the dealer and play stupid. It will be fixed under warranty. Luckily cars don't come with tamper seals like computers do.
 

·
Registered
Joined
·
101 Posts
Discussion Starter · #3 ·
i have swapped the sensor back. I thought it should have cleared itself as when you change a faulty maf i didn't think the ecu reset.

My brother has an OBD kit that can reset fault codes, do you think its worth trying.
 

·
Registered
Joined
·
101 Posts
Discussion Starter · #4 ·
Sorted it. the car must just have needed to get used to having the new sensor back. I bloody good drive sorted it out.
 

·
Registered
Joined
·
4 Posts
My car 03' 1.8T little yellow light just came on today and i dont think the turbo is spooling and i feels so slow, it's a TIP. Any suggestions guys?
 

·
Banned
Joined
·
8,975 Posts
A "little yellow light" came on, eh? Which one?

If your pre-catcon oxygen sensor is shot, then your engine computer won't be able to tell if it's injecting the right amount of gas. It's probably gone into "limp mode". Replace both oxygen sensors (they both take the same abuse, so if one's dead then the other probably is too) and clean the airflow sensor with electronics cleaner. That should take care of the problem; not having a drive-by-wire car myself, I don't know what you'll need to get rid of the limp mode, though.
 
1 - 6 of 6 Posts
Top