Volkswagen Passat Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi,
I decided to replace my old RCD500 which was broken to a new Chinese radio.
I did encounter the battery drain issue with the CAN gateway 3C0907530C, with low bat :(.

After searching about this topic, I replaced the CAN gateway 3C0907530C by a 3C0907530Q.
I did reprogram the new gateway with the old parameters, as required.
I didn't activate the navi system yet as I think it is only for having the informations displayed on the OBD.

Before connecting the new radio this time, I decided to measure and compare the battery drain current to ensure that it will not break the new battery again.
Without the car radio connected, I measured (car powered off) a short current peak at 1.2 A, which quickly goes down till around 50 mA.
With the car radio connected, I measured (car powered off) permanently 2.9 A: better say that this is not really expected, and that the issue is still present.

I don't know if this come simply from CAN parameters which are currently not enabled and that should be enabled, or if it's come from somewhere else.

I didn't find yet if it's sufficient to change the gateway by a new revision (link to pcb update), or if additional parameters needs also to be programmed.
Any idea to clarify this or how to proceed at this stage will be welcome...

Samuel
 

·
Registered
Joined
·
89 Posts
Hi,
I decided to replace my old RCD500 which was broken to a new Chinese radio.
I did encounter the battery drain issue with the CAN gateway 3C0907530C, with low bat :(.

After searching about this topic, I replaced the CAN gateway 3C0907530C by a 3C0907530Q.
I did reprogram the new gateway with the old parameters, as required.
I didn't activate the navi system yet as I think it is only for having the informations displayed on the OBD.

Before connecting the new radio this time, I decided to measure and compare the battery drain current to ensure that it will not break the new battery again.
Without the car radio connected, I measured (car powered off) a short current peak at 1.2 A, which quickly goes down till around 50 mA.
With the car radio connected, I measured (car powered off) permanently 2.9 A: better say that this is not really expected, and that the issue is still present.

I don't know if this come simply from CAN parameters which are currently not enabled and that should be enabled, or if it's come from somewhere else.

I didn't find yet if it's sufficient to change the gateway by a new revision (link to pcb update), or if additional parameters needs also to be programmed.
Any idea to clarify this or how to proceed at this stage will be welcome...

Samuel

Is your CAN Gateway without errors?
Sometimes the Chinese radios do also require address 37 (Navigation) to be active, otherwise it wil stay on and not go into sleep mode.

Other solution might also be: software upgrade your CAN Gateway to a newer version.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hello, thank for your help.
I enabled the address 37 to be active, and it solved the issue (I performed again a current measurement).
I didn't checked the errors for now, I already know that I still have some others that I need to solve :(
I'm not aware that it is possible to do a software upgrade of the CAN gateway, I was guessing that you mainly need to change the module.
Is there somewhere information's how to do this and where to grab the latest hex file of the firmware ?
 

·
Registered
Joined
·
89 Posts
Hello, thank for your help.
I enabled the address 37 to be active, and it solved the issue (I performed again a current measurement).
I didn't checked the errors for now, I already know that I still have some others that I need to solve :(
I'm not aware that it is possible to do a software upgrade of the CAN gateway, I was guessing that you mainly need to change the module.
Is there somewhere information's how to do this and where to grab the latest hex file of the firmware ?
Yes there is, but you need VAG CAN Pro + the appropriate interface for it.
The firmware files are available on the net, I am looking for them as well.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
87 Posts
Hey there! You need an upgrade to the CAN Gateway. There are several guides for this scattered about the intertubes. Sorry, I no longer know them. I used an "L" gateway. I understand anything newer than an E , (including most E's) will work. You need to code the newer gateway to accommodate your car. Mine was slightly bungled so I get a bunch of errors whenever I do a scan but it does not interfere with the operation of the car in any way. In other words it passes all inspections and doesn't compromise any emissions. Find somebody with vcds and go for it! You won't be sorry. No voltage drain for you now..lol.
 
1 - 6 of 6 Posts
Top