Volkswagen Passat Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I've read enough about Emmisions Workshop comming up in the dashboard, but I still have questions.

My car came up with the Cel and Emmisions Workshop message in the dashboard, so I took it to the mechanic and they told me I might have a bad Cat or o2 censor. There was a whole battle with my warranty prior to this, because my car's motor had to be replaced, so the shop didn't want to deal with the warranty again and they sent me to the dealer to diagnose my Cel problem.

The first shop had reset my CEL and when I went to the dealer I asked them if they would still be able to see what the problem was, they told me that it was a 50/50 chance and that if not, I would have to wait and pay another 40 dollars when the light was actually on.

So I call the first shop and asked to see what they had done with my CEL, and they told me that it should come back on and that I should wait because I better have a big CEL on when I call my warranty after what they spent fixing my motor and all.

So here am I wating, but my car has this symptoms:

1. I feel like driving with two cylinders
2. Ocational burning oil smell
3. My car has no power
4. NO Cel On as of Yet.

So should I keep wating on this, or is my car at risk? I can still drive it, as a gramma that is, but I don't feel good about it. I think my cat is plugged or something, but this people want me to wait for the CEL to come on, and it's been a week already driving my car like this.

Any suggestions?

Thanks!
 

·
Registered
Joined
·
3,559 Posts
Ask your mechanic what the code was. If it comes on again, go to Autozone and they will scan it for free. Write down the code(s) and post. Also, should we guess what car you have or do you want to tell us?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
oops, my bad:) .

I have a 2000 gls v6 passat with 86k miles on, and a 60k miles motor just installed. New Motor and enginee mounts, new belts, new breaks...(talking about breaks, this car has me broke:lol: )

The code, I don't know; but whatever it was it said that either my Catalytic Converter was bad, or an o2 censor. The guys there explained to me that if my o2 was bad the cat would warm up too much and make the CEL come on; but also that if my cat is bad, it would warm up and make the CEL come on. I'm still wating for anything to come on again, but nothing as of yet, and my car feels like crap.

I read this though.

http://www.car-stuff.com/volkswagencatalyticconverter.htm

It sounds like that's my problem, but no Cel on yet.

Here is the story with the motor, for those interested:


After around a thousand miles driven on my car (after I bought it with 86k miles on) my car was shaking like it was going to break apart, ended up being the motor and engine mounts, ALL OF THEM. I also needed breaks ($$$) and a bunch of belts, ended up saying, what the hell, I might as well fix it because i just bought this car so I want everything to be fine with it.

After that they kept working on it and found a couple cylinders bad, the trany was bad and a bunch of things, so my exteded service warranty told me this was pre-exsisting damage and they were reluntact to cover it.

I bought the car in AS-IS basis.

After talking with a bunch of managers at Mercury Insurance Group, they desided to fix my car in good will. They gave me a new motor (around 60k old, in mint condition as said by my mechanic), and they paid for the repairs.

I drove the car like 1500 miles more and I had a mixfire in one of the cylinders, that was taken care of by the repair shop just because they installed the motor. They put new plugs in the car. It was still mixfiring after a week of driving and they took care of it and replaced the cables that go to the cylinders. That took care of the mixfiring.

Now I have this Emmisions Workshop thing going on. :)

I've own the car for only 3 months by the way, the bet the previows owner swa this comming!:bowdown:
 

·
Registered
Joined
·
3,559 Posts
When the CEL comes back, you need to get the codes and post since it could be a number of things. There is a ECM software update for the 2000 V6 (based on VIN) to correct too sensitive software that triggers certain emissions related codes indicating that your catalytic converter is bad. As long as the CEL is not blinking, you can drive the car with the CEL on with no problems. Your occasional burning oil smell could be the valve cover gasket leaking on the exhaust. Also, if your gas was sitting in the tank for a while when they repaired your car, it could have become stale which can clog injectors and it could result in your poor performance and misfires. If you haven't done so, I dump a couple of bottles of techron fuel injector cleaner in the fuel tank.
 
1 - 4 of 4 Posts
Top