Volkswagen Passat Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hey guys... I am pretty lost right now.
I have 2004 VW PASSAT Manual Trans. v6

I believe there is an issue with the CCM and even after I replaced it with another I got in the junkyard, it had the same codes...?
So here are all the DTCs I got:

VAG-COM Version: Release 409.1-S


Chassis Type: 3B - VW Passat B5
Scan: 01,02,03,08,15,16,17,19,35,36,37,46,55,56,57,58,76

-------------------------------------------------------------------------------
Address 01: Engine
Controller: 3B0 907 551 DB
Component: 2.8L V6/5V G 0010
Coding: 07501
Shop #: WSC 00028
WVWRH63B04P009665 VWZ7Z0C7598993
No fault code found.
Readiness: 0110 1101

-------------------------------------------------------------------------------
Address 03: ABS Brakes
Controller: 4B0 614 517 G
Component: ABS/ESP front 3428
Coding: 04255
Shop #: WSC 00028
No fault code found.

-------------------------------------------------------------------------------
Address 08: Auto HVAC
Controller: 3B1 907 044 J
Component: CLIMATRONIC B5GP 0006
Coding: 17200
Shop #: WSC 00028
4 Faults Found:
00792 - A/C Pressure Switch (F129)
35-00 - -
00603 - Footwell/defroster Flap Positioning Motor (V85)
37-10 - Faulty - Intermittent
01271 - Positioning Motor for Temperature Flap (V68)
37-10 - Faulty - Intermittent
01274 - Air Flow Flap Positioning Motor (V71)
37-10 - Faulty - Intermittent

-------------------------------------------------------------------------------
Skipping Address 15-Airbags

-------------------------------------------------------------------------------
Address 16: Steering wheel
Controller: 1J0 907 487 A
Component: Lenkradelektronik 0005
Coding: 00118
Shop #: WSC 00028
No fault code found.

-------------------------------------------------------------------------------
Address 17: Instruments
Controller: 3B0 920 929 B
Component: KOMBI+WEGFAHRSP VDO V03
Coding: 15235
Shop #: WSC 00000
WVWRH63B04P009665 VWZ7Z0C7598993
3 Faults Found:
01336 - Data Bus for Comfort System
37-10 - Faulty - Intermittent
01336 - Data Bus for Comfort System
49-10 - No Communications - Intermittent
01330 - Central Control Module for Central Convenience (J393)
49-10 - No Communications - Intermittent
S
-------------------------------------------------------------------------------
Address 19: CAN Gateway
Controller: 6N0 909 901
Component: Gateway K<->CAN 0001
Coding: 00006
Shop #: WSC 00028
8 Faults Found:
01336 - Data Bus for Comfort System
37-10 - Faulty - Intermittent
01336 - Data Bus for Comfort System
49-10 - No Communications - Intermittent
01330 - Central Control Module for Central Convenience (J393)
49-10 - No Communications - Intermittent
01320 - Control Module for Climatronic (J255)
49-10 - No Communications - Intermittent
01331 - Door Control Module: Driver Side (J386)
49-10 - No Communications - Intermittent
01332 - Door Control Module: Passenger Side (J387)
49-10 - No Communications - Intermittent
01333 - Door Control Module: Rear Left (J388)
49-00 - No Communications
01334 - Door Control Module: Rear Right (J398)
49-10 - No Communications - Intermittent

-------------------------------------------------------------------------------
Address 36: Seat Mem. Drvr
Controller:

Sooo, what's going on is pretty typical of a bad CCM to my knowledge.... My locks (seems like just the passenger-front side) keep randomly unlocking and then occasionally locking all on their own. I looked at the wiring down below the footwell where the CCM lays and I do not see any corrosion or shortage whatsoever. I also noticed my driver-rear door would not open from the outside and it's window doesn't work. So I thought to myself: hmmm... maybe this door module is bad and causing the issues with the CCM? So I took off the door panel and the motor was plugged in yet the window wont move up or down. Still the door will not open the from the outside.

Is it possible all these weird "CCM" fault issues are coming from this door module being bad? I heard from somewhere that the CCM wiring goes through the door modules and if one faults, it causes the CCM codes. Is this right? Or what do you guys think?
 

· Registered
Joined
·
20 Posts
Discussion Starter · #2 ·
ALSO! I forgot to mention, but hopefully it will help diagnostic purposes, I noticed when I hold down the window switch for any door (for example drivers) it will go, and randomly stop going down (like it lost power to it) and then if I continue holding it down, it will eventually keep going after. It's pretty random but it will do this "losing power" thing maybe 2-6 times before I get the window fully down or up.
Hopefully this helps! This does this on all windows. (except the driver-rear of course bcuz the window doesnt move whatsoever)
 

· Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
Okay, i will be checking all those wires at all doors and see it everybodys in tact still. However, also i thought to mention, the inside dashboard clock will randomly reset every few hours back to default “12:00”. Hopefully that also helps diagnose the problem if anybody knows.
 

· Registered
Joined
·
20 Posts
Discussion Starter · #7 ·
I assume that when you replaced the old CCM, you pulled it out from under the carpet, and opened the "waterproof" case, and thoroughly inspected the connections? I don't know if they changed the design between 99 and 04, but on my 99 there are two connectors that split off that cable harness, inside the case, and plug into the actual module. I'd inspect all the pins on the connectors, both sides, and, to the best of your ability, make sure there is no corrosion or breaks in the MANY wires. You might even want to temporarily undo the harness to get an eye on all the individual wires. Make sure there is no sign of water whatsoever.
Yes sir. I have 2 plugs into the CCM. All pins and wires look great. Not even any wetness whatsoever.
Also, I noticed when playing around with the left-rear door, that the door module on that door isn't working whatsoever. Won't lock or unlock (literally motor wont even try to move) However I confirmed all the other wires in that same harness is getting power (such as speaker, window up-down, etc) So it's truly just the inside electronics in the door module that is bad. Would this cause these ccm codes because I believe the can bus wires run through the door module correct?
Could it possible be just this door module is bad and it causes all these ccm codes?
All other doors work properly, and lock and unlock when told.

Also, I inspected all plugs and wires on the bending boot on both rear doors. All those wires and plugs are fine as well.
Guessing it's just the one bad door module???
 

· Registered
Joined
·
20 Posts
Discussion Starter · #11 ·
Not sure why you're saying the module is integrated with the window motor???
This is the door module from what I'm hearing:


And this is simply a motor for the window:



Am I not correct???



P.S. Also, I changed the door's lock actuator (first picture) and for some reason, it isn't getting power when I click "lock" or "unlock" on the key. All other doors are getting power to the lock actuators. What could be causing this? Wiring to it looks fine to me.
 

· Registered
Joined
·
20 Posts
Discussion Starter · #16 ·
Wow I feel like a dumbie head.......
I replaced the lock actuator thinking that was the door module, yet infact you guys are correct, that damn window motor is the door module as well xD
Once I replaced the window motor with a new one, no more problems!!! All is working now:)

Crazy to think all this random crap was happening just because of one window motor :O
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top