Volkswagen Passat Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Having no dome lights, power locks, sunroof, electric windows, or ac compressor functions (all lost at once), I used Vag com and a Ross Tech cable to scan the car (03-W8-4motion). It has no communication with the CCM or the AC. I had already replaced the door lock module on the drivers door, and also swapped in a used CCM with all numbers matching. I have also checked all my fuses several times.
Car still has same symptoms. Unhook batt and reconnect, and the driver window and dome light work. Shut it off and window and dome light stop working.
I assume I have a break in a wire. The wiring into the CCM I've unwrapped and looked at closely and have seen no problems at any of the solder joints or the ground connection I've read about. I've also looked at the wire going through both front door boots in the hinge area. I have read to check the K-line, but am unsure which it is. Suggestions?
 

·
Registered
Joined
·
1,938 Posts
I'm no expert but I've heard the ABS module can fail in a way that causes communication to be lost to the OBDII system. Try disconnecting any electrical connections to the ABS system and re-scanning. Or search for this issue to get more details.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Have not heard mention of the ABS pulling the system down. Will do some reading on that.

No, water entry doesn't seem to be an issue on this car yet. Have read plenty on the clogged drain at the battery tray. No wet carpet or any signs of water in the recess pocket for the CCM.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Reading more on here I see that the window motor or module can also cause issues with the CCM circuit. Does each window motor or module have its own individual power/K line to the CCM or are they daisy chained?
The driver door is almost the only door that was being used when they all died, and is still the only one that has the ability to lock/unlock or raise/lower the window when I either disconnect the battery and reconnect or if I simply pull the connector off of the driver window motor and plug it right back in. No electrics work from any other door.
 

·
Registered
Joined
·
4,825 Posts
The door control modules are configured in parallel (not daisy chained); that way if one door module fails, the other three are fine. Couple extra wires in the driver's door harness are for the window close/open while key is turned in the door lock cylinder.

I would agree that searching for a break in the K-wire(?) or can-bus that the CCM is on (not familiar with the W8) should be where your efforts are spent. Once you can reestablish VCDS communication with the CCM, I think you'll be on the downhill side of solving your problem.
 

·
Registered
Joined
·
4 Posts
My wife's passat ended up with wet floor syndrome. The CCM box was flooded. I got a new one, but nothing works when I plug it in, just like the old one. Car won't start. Is this normal for a bad CCM? or should the car still at least start??
 

·
Registered
Joined
·
2,343 Posts
My wife's passat ended up with wet floor syndrome. The CCM box was flooded. I got a new one, but nothing works when I plug it in, just like the old one. Car won't start. Is this normal for a bad CCM? or should the car still at least start??
check the ground connections ,they have a tendency to "look" good ,however have a film of corrosion over them , "War Eagle"
 

·
Registered
Joined
·
10,471 Posts
The relay in position 12 on the 13 position relay carrier under the dash, is the start inhibit relay that is activated by the alarm system.
Your fault is likely in the alarm system (part of the CCM) thus not activating the relay.

To bypass the relay, remove the relay and connect a jumper across the 2 larger pins in the socket;
or remove the relay cover and hold the contacts closed while starting.


K-Line
If any part of the K-Line is shorted to + or -, it kills the whole line, and prevents scanning.
The K-Line connects to the modules inc. Original radio and the OBDII port.

Ross-Tech: VCDS: Afterrmarket Radio Problem
You can use the test near the bottom of the page to check the K-Line, and find what type of fault exists.


WATER INGRESS AND SOLUTIONS
Locate and fix source of water ingress, if any.
I suggest you completely unwrap all of the CCM harness and pull the wires apart to find the splices, any corroded splices need
to be cut back, soldered, and covered with marine grade heat shrink tubing. (You might need to add short wires to replace what you cut out)
Also check ground connections (1 on floor and on "A" Pillar), and check CCM/TCM and "A" Pillar connectors.

Have a good look at these links, before you start.

NOTE: The car in this DIY is UK RHD. (the CCM is always on LHS)
VW Passat CCM harness repair | HeadFUZZ

This thread attempts to bring together all the problems regarding water ingress and their solutions.
http://www.passatworld.com/forums/61-b5-information-base/230249-water-ingress-solutions.html
 

·
Registered
Joined
·
5,896 Posts
Well i got on here to reseach my issue with my B5, and it seems that i have found the right thread, i hope? short story, i just got my car back that was left outside for over a year, not moving. Got it running no issues, just that the windows would not roll down, interior lights on the center dash, including vents and door card lights and celling lights (sun roof works, just the lights dont) would not work. My heater control (fan control knob, low to high fan) also is not working.

I fixed the windows, found out the 30amp/12volt relay/fuse under the dash was bad and now they roll up and down including with the keys from the lock, but still no lights on the center part of the dash, celling and doors. Everything else in the car works. Any ideas? Any input on that would be greatly appriciated and i will look at the ground on the CCM as well.
 

·
Registered
Joined
·
5,896 Posts
If you mean the lights that illuminate the switches etc., check that the dimmer is not turned right down. Check the dimmer control.
You know i did not even check that so i will but the problem is that the dash ones work (RPM, speed, fuel etc...) but nothing else, steering wheel, vents, doors, ceiling lights etc...
 

·
Registered
Joined
·
4 Posts
I still can't even crank mine, so can't take it anywhere to run codes. :(

OK, Update. I took the cover off of relay 12 and held the connection and the car does start now!! :D Thx.

Can I make a jumper and just leave it there and drive it forever? or do I just need to jumper it to start it, then "un-jumper" it?
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top