Volkswagen Passat Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter #1
My mechanic says the Aux fan control unit is burned out on my car, however he didn't give me the part number but said it was located on the front drivers side wheel.

I was wondering if anybody knew the location of the Aux. Fan Control Unit on a 2004 Passat GLX 2.8 4motion and I believe the part # is (8D0 959 501C) or C158 98-05 VW.
 

·
Registered
Joined
·
26,096 Posts
It's under the front driver's side frame, right behind where the bumper supports are bolted.
 

·
Loose female member
Joined
·
4,885 Posts
$20 from my local pick and pull. As mentioned, very rarely go wrong. Are you sure its not the fan itself? Hell the tech should know.
But,
 

·
Registered
Joined
·
262 Posts
Discussion Starter #6
Yeah my tech said there is no power going to the fan at all so most likely is that switch since it has power going to it.

I'm just trying to find the exact location of the switch so I can go pull it myself now.
 

·
Loose female member
Joined
·
4,885 Posts
Pretty cramped to get out but as mentioned, front right behind the bumper, a couple of 10mm nuts and some connectors to separate.
Get to it from underneath the car. remove the sound deadening panel and it's right there.

Are you sure your AC system has pressure? if not this aux control will not power up the fan.
 

·
Registered
Joined
·
26,096 Posts
I would suspect the fuse or relay before the control unit.
 

·
Registered
Joined
·
8,940 Posts
Are you aware that the fan doesn't run unless the engine and AC are on, or the coolant is above normal operating temp.
 

·
Registered
Joined
·
262 Posts
Discussion Starter #10
Yeah, this has been an ongoing issue with my AC not working or not working as well as it should for sometime just in the last 2-3 months the AC pretty much stopped working at all....it might blow cold for a few minutes then it starts blowing hot air even if it's cool outside.

I ran a diagnostic on my climate control and it states it's working fine with no errors and the last place I had look at it before I could get it over to my normal VW tech said the fan was shot but the fan seems to work fine when it has power. My Tech stated he is 99% sure it's the module so I'm assuming he checked the relay and furse, but just to be sure where are the relay and fuse on it, I might just replace them as well.
 

·
Registered
Joined
·
8,940 Posts
There are 2 fan fuses and 1 relay on the aux relay panel under the dash. The module replaces the 2 fan speed control relays.
 
1 - 11 of 11 Posts
Top