Volkswagen Passat Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1
Several weeks ago I had a CEL with the following codes.

16804 PO420-002 Catalyst System Bank1

16840 PO456-001 very small leak detected intermittent

16684 PO300-008 Random/Multiple Cylinder Misfire Detected Intermittent

16688 PO304-008 Cylinder4 Misfire detected Intermittent

I re-did the coil pack ground wire connections at the top of the cylinder head and that seemed to cure the misfire codes. The engine was running noticeably better, but of course the CEL was still present.

This week I finally got around to replacing the lower o2 sensor hoping to eliminate the PO420-002 code.

Well the CEL is still on but the engine is running sweetly, very strong and I had another scan done.

This time, 2 Faults Found,

17881- EVAP leak detection pump
P1473-004 Open circuit MIL ON

16804 Catalyst System, Bank 1
PO420-002- Efficiency Below Threshold-Mil ON

It appears I did something wrong with the installation of the new O2 sensor as it didn't cure the PO420-002 code, or should I be looking elsewhere?
And, how should I go about checking the P1473-004?
All suggestions kindly accepted. Thx
 

·
Registered
Joined
·
5,335 Posts
The catalyst code is indicating a bad cat. If the O2 sensor was bad or incorrectly installed, you'd have a code specifically saying this. (The normal failure mode for a post-cat sensor delivers an incorrect "everything is fine" indication, not a false code saying the cat is bad when it isn't.)

If you live in CA, the fix is expensive, if you don't live in CA, there are plenty of perfectly good aftermarket replacements that are not very spendy.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
123 Posts
Discussion Starter #3
Thank you sirwired. We did plug both exaust outlets and found a small leak in the flex pipe so that's a start. I'll take the wagon to my garage this week for a hands on opinion. I'll schedule a flex pipe replacement and some how get their opinion on the cat itself.
They are wonderful little vehicles but they sure are sensitive to the smallest thing being askew.
I have too many vehicles currently and may want to sell the 4 motion, therefore the reason to eliminate the CELs, but it's such a wonderful snow vehicle that I know I'll miss it come the first snowfall. Decissions, decisions .
 

·
Registered
Joined
·
1,339 Posts
In my experience, nothing cured a P0420 except a new cat. If yours is borderline (barely not passing efficiency) you might be able to "improve" the reading a little with a spacer.
BTW, a new post cat sensor makes the cat look a little bit worse, not better.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #5
Well, I've had the down pipe/flex pipe replaced along with the lower O2 sensor. The vehicle is running very nice with lots of power.

There still is a CEL and the code is 2400 Evaporative Emission System Leak Detection. Pump Control Circuit Open.

How do I further troubleshoot this problem, where do I look for the pump control circuit?

Thank you.
 
1 - 5 of 5 Posts
Top