Volkswagen Passat Forum banner
1 - 1 of 1 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi everyone, I have an ongoing issue with my 2009 2.0 TSI B6 Passat that I can't seem to figure out. I've had the car for five years; just a few months into owning it, I had a new throttle body and throttle body harness installed because the EPC light came on (with the rev limiter also coming on). This was many years and about 25,000 miles ago -- but in late 2019, I started seeing the same symptoms (error code P0221). I wasn't using the car at the time so I decided to see what happens, and I've been able to establish this pattern in the past year and a half:

1. In cold weather, from about November until April, the car is error-free.
2. During the warmer months, the EPC light comes on shortly after a cold start. (I use the car very rarely now -- a few times a month.). If I wait about 15 minutes and reset the VAG code, or even just restart the car, the problem goes away and the car drives fine.

I think it's worth mentioning that the instrument cluster seems to have a problem, which I think might be related to the EPC issue as well. (If I engage the electronic parking brake, it will detect an error, although the brake will hold the car. If I start the car and disengage the EPB within about 5 seconds, I can avoid the error light and message. This problem came up after I replaced the rear brake pads, and my mechanic says it can be solved only by replacing the instrument cluster.)

Do any of you have experience with similar situations? Any help would be appreciated -- thanks!
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top