Volkswagen Passat Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have a 99 VW passat I had to replace the Comfort Control Module. It was filled with water and well destroyed it along with the pigtails I was able to to get new pigtails and a new CCM and was able to connect all the wires to new pigtails except for one wire. I am hoping someone has the wiring diagram of the CCM along with the wire coloring. Please Help!!!!
 

·
Moderator/Administrator
Joined
·
24,198 Posts
Please make sure you post in the correct forum per the sticky threads in the new members area, which you were supposed to read over and post there first. I moved this to the correct forum, the B5 area.

What color was the extra wire?
 

·
Registered
Joined
·
1,280 Posts
Per Bentley schematic 29/17, there is a red/yellow (red with yellow stripe) wire, 1.5 mm2 (about 14 AWG), on pin 12 of the CCM. It is the power feed from fuse S144, 15 amps; the fuse in on the 8-fold relay panel, not in the main fuse box.
FYI, the red/black wire on pin 15 is the power from fuse S111, also 15 amps, also on the 8-fold relay panel.
This assumes the care was made from August 1998 on.
 

·
Registered
Joined
·
1,280 Posts
It probably will start the car. The CCM has to energize a relay, signifying that the alarm is disarmed, in order for power to get to the starter. Thus a blown (or disconnected) power wire to the CCM will usually result in a no crank condition.
 

·
Registered
Joined
·
1,280 Posts
I don't have a diagram, but there are probably numbers molded in to the connector, if only in the four corners. It will be numbered either across-then-down or down-then-across, but you can figure that out from the four numbers. Also look at the mating connector in the CCM--the numbers may be easier to see there.

Alternately, search the forum for photos of the CCM connector and play match the colors. Also, in Post #4, I give the colors for pins 12 & 15, so you may be able to deduce it from there.

If all else fails, take a picture of your connector and I can compare it to the schematic.
 

·
Registered
Joined
·
1,280 Posts
Clarifying the wire color:
The base color is always listed first, then the stripe color.
For example, a red wire with a yellow stripe is "red/yellow" or maybe "red w/yellow."

Is your wire red/yellow or yellow/red?
 

·
Registered
Joined
·
1,280 Posts
Bentley schematic 29/17 shows three 0.5 mm2 wires from the 15-pin CCM connector to the Red 10-pin connector at the A-pillar (beside drivers left foot). I'll list all three here for ease of location:
15-pin CCM 10-pin Red Wire Color
Pin 8 Pin 1 Yellow/Red
Pin 9 Pin 2 Yellow/Green
Pin 2 Pin 2 Yellow/Brown

The odd thing is the schematic just stops at that connector, as if nothing connects to the other side. I believe the mating connector goes to the roof wiring harness, but I can't think of what the wires might be for. Maybe something not present on US cars.

Check the mating connector and see if there are wires there. If not, you can just cut and insulate.
 

·
Registered
Joined
·
27,118 Posts
I thought the light blue was the roof harness, at least for the front overhead lights and sunroof.
 

·
Registered
Joined
·
1,280 Posts
Bentley schematic 29/17 shows three 0.5 mm2 wires from the 15-pin CCM connector to the Red 10-pin connector at the A-pillar (beside drivers left foot)<snip>
PZ (post #14) made me look, which found an error in Bentley.
Schematic 29 says the connector is red.
Schematic 51 says red on 51/17 but green on 51/18.
Schematic 82 says green everywhere.
The connector list on page W 97-3 says left A-pillar connector 3 (top right) from Floor to Roof harness is red.

I wouldn't be surprised if it changed somewhere along the way. I'd be only slightly more surprised if it were light blue.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #17
Ok. Engine is running now I got another issues the vacuum lines on top of the throttle body are all jacked up anyone have a diagram or advice one what to do.
 

·
Registered
Joined
·
27,118 Posts
PZ (post #14) made me look, which found an error in Bentley.
Schematic 29 says the connector is red.
Schematic 51 says red on 51/17 but green on 51/18.
Schematic 82 says green everywhere.
The connector list on page W 97-3 says left A-pillar connector 3 (top right) from Floor to Roof harness is red.

I wouldn't be surprised if it changed somewhere along the way. I'd be only slightly more surprised if it were light blue.
Well, mine is a B5, so it could well have changed.
 
1 - 20 of 26 Posts
Top