Volkswagen Passat Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello all, my problem seems awfully unique as I've spent the last 2 days scouring forums for these codes. Alas, none can be found, so here's my issue -

Bought this car clean, 96k for $2k. No codes, first stop on the way home was my mechanics house. He popped the plastic covers and immediately noticed my PCV was coated in electrical tape from end to end, as well as my coolant tank was cracked. Both replaced two days ago, and my fuel mileage dipped to extreme lows (~8mpg in first gear, usually above 2 and 3 I get more like 12-18) Trip home yesterday threw four codes. P0150 (bank 2 sens 1), 16534 (bank 2 sens 2), 17930 (cam position sens I think?), and 532 (voltage fluctuations). Today I will clean my battery terminals and try and clear codes, I have a suspicion that these codes were held from when my previous PCV was installed, but I'd love for someone to have a clue as to what's happening. Engine is a 2.8L 30V. Thanks in advance y'all

Caelan
 

·
Registered
Joined
·
26,305 Posts
8 mpg in 1st is not unusual. It's the overall average that matters as you hopefully do not stay in 1st very long. If you want better mpg, the V6 is comfortable shifting at 2K if you drive sedately.
For the codes, I would start with the CCT: 17930 P1522 Intake Camshaft Contr.,Bank2 Malfunction
Depending on the care the engine received, it could be a bad CCT actuator (cam chain tensioner is also the adjuster).
It's not a cheap job and the parts are expensive. If you are lucky, it's simply a bad connection on the electrical side. It's the tan plug at the bottom right of this engine:
97655


The 16534 P0150 (it's only 1 code), O2 Sensor Circ.,Bank2-Sensor1 Malfunction is probably due to either a dead sensor or most likely, a exhaust leak at the flex pipe.

The last code needs to clarified: 16916 P0532 A/C Refrigerant Pressure Sensor Circuit Low Input.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks a million for that pic, been trying to decipher wiring diagrams all day.

Waiting for my garage to finish work, then I'll see if I cant sort this out. Updates coming soon
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Okie dokie pretty sure it's a valve cover gasket, slowly coming out the passenger side closer to the firewall. Cleared the ECU manually, as I have no code reader, so I'm gonna see if she throws codes at me before Monday, then going to a shop to replace the gaskets.

Also named her today, El Diablo 😁😁 it's a tad cheesey, but the only thing the owner left me besides an empty oil filter box was a receipt in the glove box for El Diablo state park last year on christmas day.

More to come. Emotionally invested now.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Hopefully this did it. Cracked the valves and found that the Cam Chain Tensioner had lost its plastic head, cause for all the noise was plastic bits floating around. All replaced and sound now. Thanks for totally calling it 🤟🤟
 

·
Registered
Joined
·
26,305 Posts
Luckily there was no other damage. Several people have bent valves when this has happened.
 
1 - 7 of 7 Posts
Top