Volkswagen Passat Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 20 Results
  1. Volkswagen Passat B5 Discussion
    Hello all. 2003 B5.5 GLX 4motion wagon, about 235K miles. Had an MIL light for some time, MAF sensor code. Replaced that, erased codes, light out. Sweet. Then a P0340 CPS code. Had already swapped out the one on passenger side, now did driver's side. Erased codes, P0340 came back after about 4...
  2. Volkswagen Passat B5 Discussion
    We've owned a 2003 Passat 1.8 AWM for going on 3 years now. Shortly after purchase the CCT exploded allowing the cam chain to eat a few slits in the valve cover. With much sweat, swearing and assistance from this forum I replaced the CCT, dropped the oil pan, cleaned it all out, replaced the oil...
  3. B6 Garage
    My car started to really drag ass this morning, I scanned it with my VAGCom and got the code above. I changed the cam position sensor and it still runs the same way, rough idle and no power on the street. I changed the timing belt, tensioner and all other parts 20,000 miles ago and the car has...
  4. Volkswagen Passat B5 Discussion
    I have been searching the forum trying to get a lead on a recent issue with our 2001 1.8T wagon, AWM, automatic with 130K miles. It still is running seemingly normal, temps normal, no warning messages. Going to check the oil pressure mechanically tomorrow. Backstory on the car, about 18 months...
  5. Volkswagen Passat B5 Discussion
    I intermittently get a P0340 code. I changed the camshaft position sensor with a genuine vw part and still get the intermittent P0340 code. I've tried the wiggle test on the wires and connector (wiring harness connector) and couldn't get the car to produce the P0340 code. I tested continuity of...
  6. B5 Garage
    Engine idles a bit rough. I get random codes P0340 and P0012. Immediate thought was bad cam sensor so I replaced that. Still getting the codes and the rough idle. As soon as you give it the slightest amount of throttle it runs like a champ. Codes only pop at idle. Thoughts? Thanks.
  7. Volkswagen Passat B5 Discussion
    I had a P0340 recently but after clearing it went away. We just had a warm up weather wise. Should I change the camshaft sensor? Passat V6 GLX 2.8L 2003
  8. Volkswagen Passat B5 Discussion
    We changed the oil pump and cleaned the intake tube and now the car runs bad? Now it has multiple codes such as p0340, multiple misfire codes ect... We checked and cleaned the crank position sensor and cam position sensor. The car runs great at 2000 RPM's and over. It idles terrible...
  9. Volkswagen Passat B5 Discussion
    I have just rebuilt my engine and I got it all back together and in the car. I go to start it and it starts up sometimes and when it starts it sounds like the car is running rough and now I get the code P0340 Camshaft Position Sensor A - Bank 1 Circuit Malfunotion. the car runs the same with or...
  10. B5 Garage
    First, I want to assure you that I have searched the B5 garage forum looking for my answers. But for some reason, nothing I search for returns any results. Literally, nothing. So here's the issue: 2004 Passat Wagon, AT, AWM engine. CEL came on today. Code check showed P0011 and a previous...
  11. Volkswagen Passat B5 Discussion
    I changed the timing belt on my '01 Passat (2.8) about a year ago and recently I have had a P0340 Code. I read that this could be from the timing belt having jumped a tooth. If i clear the code, it immediately comes back. The car runs perfect but does run a tad rough, not bad though, at idle...
  12. Volkswagen Passat B5 Discussion
    I'm kind of stuck here. I have a 2005 1.8t passat that I have had bad run-in with a couple mechanics. First I had a bad head gasket, was assured it wasn't, thus lead to the cracked head. The second mechanic after hiding fees changed the head with one he claimed was going to use on a Jetta he...
  13. Volkswagen Passat B5 Discussion
    Replaced the CPS, now the CCT is making ALL kinds of noise like it's not getting oil and I am getting the P0299 & P0011 - so what controls the oil pressure to the CCT - I am assuming that there must be an oil pump but not getting a code for that. I will adjust the timing as it is advanced per...
  14. Volkswagen Passat B5 Discussion
    I have an '03 1.8 Auto that I am getting P0340 (Sensor A circuit Bank 1 or Single Sensor) after letting the car warm up and the driving for about 2 miles - the CEL is on & got the flashing STOP. My mechanic has replaced the CCT, TB, WP, new plugs & seals - now this? Any ideas? I have read...
  15. Volkswagen Passat B6 Discussion
    I have been having issues periodically with the car while in drive, at idle/stopped, having it lurch or idle rough (rpm's are steady though) and almost bounce at times and the headlights pulse dim and bright. I have also at these times had low power acceleration. It usually happens after...
  16. Volkswagen Passat B5 Discussion
    Hi all, Newbie here with 04 B5.5 with 1.8T AWM. Love the car, but getting some codes lately. History- bought car new in 04, did all my own oil changes every 5k with Mobil 1 0w-40 since new. Car now has 73k and drives perfect. No clatter, no funny noises, runs as good as new. No engine work...
  17. B5 Garage
    I have a 2003 with a 1.8 AWM engine. It idles rough but runs ok at higher rpms. The cel lite is on and I'm getting codes P0340 cam position sensor, P0300 random cylinder misfire, P0303 cylinder 3 misfire P0304 cylinder 4 misfire P0302 cylinder 2 misfire and P0301 cylinder 1 misfire I can't...
  18. B5 Garage
    I have a 2003 Passat with a 1.8 and I'm getting code: P0340 cam position sensor circuit malfunction, I’m also getting code: P0302 cylinder #2 misfire, as in no spark on the # 2 cylinder at all, ever. I swaped the cam position sensor with one from another Passat and there was no impovement...
  19. Volkswagen Passat B5 Discussion
    This is my first post on this forum and have been using it as a great tool since I purchased by Passat. Let me preface by saying the code was read by a friend with a machine and it states: CamShaft Positioning Sensor Bank 1 Circuit Malfunction. I have a 2003 Passat 1.8t. My wife and I bought...
  20. Volkswagen Passat B5 Discussion
    I recently replaced the timing belt on my 02 1.8L Passat. After running the car a good 20 minutes I got a P0340 CEL. Its the camshaft sensor alignment. The car runs great and isn't sluggish. It sounds like it's in time, but it seem too weird that that sensor would go bad after doing the TB...
1-20 of 20 Results
Top