Parking Brake Light Fault
NEWS
 

+ Reply to Thread
Results 1 to 8 of 8
  1. #1
    Neutral
    Join Date
    May 2011
    Location
    Belfast
    Posts
    5
    Blog Entries
    1

    Question Parking Brake Light Fault

    Was just wondering if anyone can help me with a problem I have a 2007 vw Passat 1.9 the problem started when I had to change the clutch master and slave cylinder on my car now when I turn the ignition on it comes up on dash parking brake fault and the amber parking light stays on when engine is started have got a scan done and it said that it was parking brake module but my problem is that the parking brakes still work the ABS still works everything is working ok but I can't get the warning light to go out. THANKS FOR ANY HELP IN ADVANCE

  2. Remove Advertisements
    VW Passat Forum
    Advertisements
     

  3. #2
    Neutral
    Join Date
    Apr 2012
    Location
    Akron ohio
    Posts
    14
    I also had same problem with p. Brake fault. Couldn't clear the code with scanner and bought new switch that still did not work. Finnaly broke down and took to dealership. Said it was the electric brake module. It cost almost. $800 and it took 3 and half days to program with help from region rep. Works great now.

  4. #3
    Neutral
    Join Date
    Jan 2012
    Location
    IL
    Posts
    48
    Have the same problem, no way I'm paying $800 to remedy it. I guess I'll have to deal with the annoyance when it chimes in every couple of weeks

  5. #4
    Neutral
    Join Date
    Sep 2012
    Location
    Canterbury
    Posts
    11
    Hi, I dont know if anyone is still monitoring this thread but I have a problem with my 2006 SE Electronic Parking Brake Sensor (I think)
    When the ambient temperature is warm out and the car has been parked in the sun, I switch the ignition on and almost immediately it pings (Very annoying) up with the "parking brake fault" light and the message "PARKING BRAKE FAULT - SEE OWNERS MANUAL" This goes off but pings up again intermittently when I take my foot off the accelerator and apply the brakes. However, the EPB itself is functioning fine! Strangely, once I have the aircon on and the car gets down to 18 degrees or in the cabin, the fault light and message stop coming up! once the car gets warm again (ie: aircon off and windows open) it will soon start popping up again! I have it booked in for a service at my local Volksline service centre and they are going to have a look at the above for me as well but I would like to know more about it so they cant rip me off!

  6. #5
    Neutral
    Join Date
    Oct 2012
    Location
    Cheshire England
    Posts
    3
    I got the parking brake fault message last Saturday and struggled to move the car - took several cycles to get the EPB to release.

    I had to have the O/S rear brake caliper replaced yesterday due to a cracked electronic parking brake motor body. Had an OE caliper fitted by the independent garage I have used for years. But still over £350.00

    My question is - can I paint the plastic motor body with stone chip type paint or similar to protect it and the original on the N/S from any further damage; and another big bill for me? In fact, is it even worth doing that?

    Obviously in an effort to keep initial build cost down, means plastic bodies are used by VW (and TRW the OE supplier) over something as simple (and stronger) as tin.
    Last edited by cheshirepassat; 10-31-2012 at 01:46 PM.

  7. #6
    Neutral
    Join Date
    Apr 2011
    Location
    Indianapolis
    Posts
    4
    I too have a problem with my parking brake. The warning in the MFD displays the infamous.."Parking Brake Fault". Here is the situation, although the warning is there, the brakes are not engaged. I replace the switch and the problem still persist. Lately, sometimes warning is there and sometime it is not. An additional strange issue is when I shut the car off, the brake light in the dash and the EPB switch both flash twice, and simultaneously you can hear the rear caliper engage then disengage. Any advice would be greatly appreciated......Thanks forum....

  8. #7
    2nd Gear
    Join Date
    Jan 2009
    Location
    LONDON, U.K.
    Posts
    511
    Could you post your Autoscan? Others in here will then see what's being flagged up

  9. #8
    Neutral
    Join Date
    Mar 2012
    Location
    palm springs
    Posts
    47
    i have that warning and the airbag as well, none of them are affecting anything at all, it drives fine just the lights are there which are annoying. the airbag light came one day i was on the freeway and the wife got up to give the baby some food, so no accident or anything, btw 2 more payments on my truck and i will be trading this pos vw, tired of spending money on it, rather have a payment on a brand new car.i

  10. Remove Advertisements
    VW Passat Forum
    Advertisements
     

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2