Electronic parking brake problem
NEWS
 

+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 30 of 38
Like Tree2Likes

Thread: Electronic parking brake problem

  1. #1
    3rd Gear
    Join Date
    Jul 2008
    Location
    SOUTH BAY, CA
    Posts
    1,046

    Electronic parking brake problem

    Ive got a b5 and my dad has a b6(07 passat variant), but he's having problems with his e-brake. it would never engage and always gave a parking brake fault. so he took it in today for regular service, they said that its not the switch but they said they cant fix it without replacing some board, which happens to cost $1000 just in parts. so hes told them not to replace the board, and live without the parking brake. any ideas on anything else i could do to fix this problem without the massive bill?

  2. Remove Advertisements
    VW Passat Forum
    Advertisements
     

  3. #2
    2nd Gear
    Join Date
    Jul 2007
    Location
    Slovakia, Kosice
    Age
    49
    Posts
    645
    Quote Originally Posted by jhorkey View Post
    Ive got a b5 and my dad has a b6(07 passat variant), but he's having problems with his e-brake. it would never engage and always gave a parking brake fault. so he took it in today for regular service, they said that its not the switch but they said they cant fix it without replacing some board, which happens to cost $1000 just in parts. so hes told them not to replace the board, and live without the parking brake. any ideas on anything else i could do to fix this problem without the massive bill?
    I got problem with e-brake last winter...The problem was that something was in the brake system and when it was cold, the e-brake didnt work. They solved it in VW, by cleaning it...
    Last edited by Allbacore; 12-16-2008 at 09:54 AM.

  4. #3
    I would go for the switch in the first place anyway. Had the same problem on my 07 variant, VW changed the switch and problem solved.

  5. #4
    3rd Gear
    Join Date
    Dec 2005
    Location
    Midlo, VA 04/S4
    Posts
    2,486
    Blog Entries
    1
    Quote Originally Posted by jhorkey View Post
    Ive got a b5 and my dad has a b6(07 passat variant), but he's having problems with his e-brake. it would never engage and always gave a parking brake fault. so he took it in today for regular service, they said that its not the switch but they said they cant fix it without replacing some board, which happens to cost $1000 just in parts. so hes told them not to replace the board, and live without the parking brake. any ideas on anything else i could do to fix this problem without the massive bill?
    I would think it would be covered under warranty...so who cares how much the parts are...or am I missing something?

  6. #5
    3rd Gear
    Join Date
    Jul 2008
    Location
    SOUTH BAY, CA
    Posts
    1,046
    Apparently its not covered, and there is over 65k miles on the car so thats probably why its not being covered

  7. #6
    3rd Gear
    Join Date
    Dec 2005
    Location
    Midlo, VA 04/S4
    Posts
    2,486
    Blog Entries
    1
    Wow...65k miles in under 2 years.

  8. #7
    2nd Gear
    Join Date
    Jul 2007
    Location
    Slovakia, Kosice
    Age
    49
    Posts
    645
    Quote Originally Posted by MP33dave View Post
    Wow...65k miles in under 2 years.
    I ve got 40K miles in one year Thanks to our "driving" job

  9. #8
    3rd Gear
    Join Date
    Dec 2005
    Location
    Midlo, VA 04/S4
    Posts
    2,486
    Blog Entries
    1
    ugh...no thanks. I love to drive, but not like that.

  10. #9
    3rd Gear
    Join Date
    Jul 2008
    Location
    SOUTH BAY, CA
    Posts
    1,046
    ya, he drives quite a bit. anyone have any ideas about this stupid parking brake fix?

  11. #10
    Neutral
    Join Date
    Aug 2006
    Posts
    56
    Quote Originally Posted by KlausJ View Post
    I would go for the switch in the first place anyway. Had the same problem on my 07 variant, VW changed the switch and problem solved.
    Same here with my '06--same symptoms as the original poster--and VW replaced the switch under warranty two years ago. No problems ever since.

  12. #11
    3rd Gear
    Join Date
    Jul 2008
    Location
    SOUTH BAY, CA
    Posts
    1,046
    the dealership ended up paying for the parts, we just had to pay the labor. so not too bad

  13. #12
    Banned
    Join Date
    Sep 2006
    Location
    Ashburn, VA
    Age
    31
    Posts
    8,987
    [rant about overengineering bullshittery deleted]
    Last edited by deusexaethera; 12-17-2008 at 12:35 PM.

  14. #13
    Neutral
    Join Date
    Nov 2008
    Location
    KSA
    Age
    29
    Posts
    29
    i had this problem... twice !!
    look
    i called the dealer and they told me how to fix it..
    unplug the battery for 10 minutes then plug it again then press the breaks for 35 seconds
    after that, while pressing the breaks press the e-breaks for 10 seconds..
    (( i think these are the right times ))
    then the cars computer will restart and the problem will be fixed !!

  15. #14
    Neutral
    Join Date
    Oct 2009
    Location
    Ireland
    Age
    50
    Posts
    1

    Parking Brake

    fsnas,
    What a man !!
    I drive a Passat 2007, station wagon.
    Had parking brake - first intermittent problem, then totally out of service.
    Also system was making warning sound / bing ... even when car was driving.
    Local VW garage said they could not see me until 3 Nov - and would cost EUR 150 min to fix !!

    Searched the web .. found this forum ..
    Tried your reset formula.
    Brake now working perfect.

    Many thanks.

    Joe (from Ireland).

  16. #15
    1st Gear
    Join Date
    Mar 2005
    Location
    Eastern Townships, Quebec
    Posts
    175
    Quote Originally Posted by MP33dave View Post
    Wow...65k miles in under 2 years.
    I think the '07 wagons came out in mid-'06 so that could be in 3 years depending on when he took delivery.

    Mine was delivered in Feb. '07 so it is a couple of months shy of 3 years, and I put 63k miles on it

  17. #16
    Neutral
    Join Date
    Nov 2009
    Location
    Cardiff, Wales. UK
    Age
    77
    Posts
    1
    Further to Joe Reid and especially FSNAS, thanks for the info.
    I had the same problems. First, wouldn't disengage, Fault indicated,look in manual, but only found entry P16 under 'Caution', disengaing in neutral; that worked. But yesterday, wouldn't engage, had to park 'in 1st gear'. then found this site and followed FSNAS's cure and now all's back to normal. For good, hopefully.
    In view of the 65k mileage item, you might be interested to know that this is my fourth Passat (Estate Sport TDI), and my first one was the 1600cc 'L' estate, In-line engine but front-wheel drive. Over 8.5 years I did 228K business miles and NEVER had to put any oil in that engine!!! just regular servicing. The drum-brake shoes on the back wheels were the original factory fitted ones when I traded the car in. now that's good German engineering for you.
    Thanks again to you both,
    Bryan.
    Cardiff, Wales UK

  18. #17
    Neutral
    Join Date
    Feb 2010
    Posts
    1

    Parking brake

    Had exactly the same problem with my 06.initially an intermittent problem--randomly the switch would stay lit up and warning light on dashboard with no brakes!!!
    Problem became permanent.
    Can't thank you guys enough!!!!Would very much like to shake your hand and thank you in person.
    By the way.I've had a problem with the e brake sticking on.Similar soution---disconnect battery for ashort time,then reconnect.
    Thanks again
    Quote Originally Posted by fsnas View Post
    i had this problem... twice !!
    look
    i called the dealer and they told me how to fix it..
    unplug the battery for 10 minutes then plug it again then press the breaks for 35 seconds
    after that, while pressing the breaks press the e-breaks for 10 seconds..
    (( i think these are the right times ))
    then the cars computer will restart and the problem will be fixed !!

  19. #18
    Neutral
    Join Date
    Feb 2010
    Location
    Chicago
    Posts
    42
    very useful info.!

  20. #19
    Neutral
    Join Date
    Dec 2005
    Location
    NA
    Posts
    133
    Quote Originally Posted by npdgroupindore View Post
    This is for all the forum members !

    As this is the new product launched and I just want to introduce this on forum
    specially for the electronics crazy forums.

    This, I got after the extensive research on internet and I think that they are good and affordable.

    Please have a look if it suits you. Thanks for the cooperation

    RC Helicopter Camera
    F^&$ this spammer

  21. #20
    Neutral
    Join Date
    Apr 2010
    Location
    Cork, Ireland
    Posts
    82
    Quote Originally Posted by MP33dave View Post
    Wow...65k miles in under 2 years.
    I have a 07 tdi passat with 250k kms on the clock..

  22. #21
    Neutral
    Join Date
    May 2010
    Posts
    52
    Anyone thought of just pulling the fuse for the parking brake?

  23. #22
    Neutral
    Join Date
    Sep 2010
    Location
    Beds, UK
    Posts
    5
    Quote Originally Posted by fsnas View Post
    i had this problem... twice !!
    look
    i called the dealer and they told me how to fix it..
    unplug the battery for 10 minutes then plug it again then press the breaks for 35 seconds
    after that, while pressing the breaks press the e-breaks for 10 seconds..
    (( i think these are the right times ))
    then the cars computer will restart and the problem will be fixed !!
    Had the same problem with my 2006 2.0TDi estate a few weeks ago. Called the RAC man and he did something very similar to the above which fixed the problem...temporarily!
    Yesterday it happened again, hence my search for this forum. Fortunately I was at home and could use my wife's car (a 2001 Golf with a conventional handbrake) so was not stuck too badly.
    I am now waiting for the RAC again and this time I will watch more closely what he does.
    I hope this is not going to be a recurrent problem. From what I have read about the stupid e-brake on B6 Passats I am not so sure.
    The first time this problem happened was after a very heavy rainstorm. This time was after jet washing the wheels, so I wonder if water is getting in to the wiring or actuator.
    My last car was an '03 B5 TDI 130 estate which never gave me a day of trouble over 150k miles.
    You can see I am a fan of VWs, but this car may well change that...

  24. #23
    My e-brake button did fail again after a few months over 3 years, but the dealer did change it again on warranty since it has been replaced before. The driving distance is now 95.000 km.

  25. #24
    Neutral
    Join Date
    Sep 2010
    Location
    Beds, UK
    Posts
    5
    Fault is happening more frequently now - refusing to engage or disengage. According to the previous owner the switch has been replaced before, but may be worth trying again. I guess it would be an easy DIY job?

  26. #25
    Neutral
    Join Date
    Aug 2007
    Location
    SGP
    Posts
    114
    Hi, at how many km did you change your timing belt? TIA

    Quote Originally Posted by SARASON View Post
    I have a 07 tdi passat with 250k kms on the clock..

  27. #26
    Neutral
    Join Date
    Apr 2010
    Location
    Cork, Ireland
    Posts
    82
    Quote Originally Posted by Black Beauty View Post
    Hi, at how many km did you change your timing belt? TIA
    Every 100k kms.

  28. #27
    Neutral
    Join Date
    Sep 2010
    Location
    Beds, UK
    Posts
    5
    Fault is now permanent. Resetting makes no difference.
    I have set up a Facebook group on this subject. Please join and contribute.
    http://www.facebook.com/?ref=home#!/...72638656097468

  29. #28
    Neutral
    Join Date
    Oct 2010
    Location
    London
    Posts
    19
    Quote Originally Posted by fsnas View Post
    i had this problem... twice !!
    look
    i called the dealer and they told me how to fix it..
    unplug the battery for 10 minutes then plug it again then press the breaks for 35 seconds
    after that, while pressing the breaks press the e-breaks for 10 seconds..
    (( i think these are the right times ))
    then the cars computer will restart and the problem will be fixed !!
    OMG I just followed your instruction man, and you know what it worked, holy sh***t man ,you are the man,because you saved me alot of ££££.£££,and also my e-brakes failed working 1 o'clock in the morning I couldn't move, but here you go thanks to the man, and problem was solved in 15 min. Thanks man.!
    seguro1980 likes this.

  30. #29
    Neutral
    Join Date
    Dec 2010
    Posts
    1

    Fixing those pesky e brake buttons

    has happened to me three times - 2006 Passat Turbo diesel - second time button was 'replaced' by dealer - happened again today - each time during wet and humid conditions.

    Quicker fix than fsnas

    1. Unlock car
    2. Unplug negative terminal keeping keys out of the way (so you don’t accidentally press anything) and leave unplugged for 10 seconds or so.
    3. Reconnect
    4. Lock car
    5. Unlock car
    6. Insert key to light up dash but don’t start car
    7. Remove key
    8. Lock car for 10 seconds
    9. Unlock car
    10. Insert key but don’t power up
    11. Unlock park brake with foot on brake – YAY!!!
    12. Power up
    13. Warning lights may be (anti skid control, tyre pressure, steering etc)
    14. A quick drive round the block should correct the above if not into VW for resetting.

  31. #30
    Neutral
    Join Date
    Dec 2006
    Location
    Brisbane Australia
    Posts
    30
    I am on my 3rd switch. You can apply/release handbrake (if it's just the switch)

    apply: use auto-hold to drive around and put it in park and turn off the car, handbrake will apply
    release: start the car, put on your seatbelt, grab D or R, and when you press the accelerator, the handbrake will release

    good luck!

  32. Remove Advertisements
    VW Passat Forum
    Advertisements
     

Thread Information

Users Browsing this Thread

There are currently 9 users browsing this thread. (0 members and 9 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2