ABS ECU Replaced but light is still on
NEWS
 

+ Reply to Thread
Results 1 to 17 of 17
  1. #1
    Neutral
    Join Date
    Aug 2006
    Posts
    11

    ABS ECU Replaced but light is still on

    Hello,

    I have just got an older used ABS ECU instead of mine, which was faulty - no communication at all. I have replaced the electronic part of the unit. But the ABS light won't go off. I can connect to ABS via VAG and there are no error codes. However there are still errors in the CAN-gateway control unit and in the instrument panel - both say
    01316 - ABS control module
    49-00 - no communication

    The car is 1999 Passat B5, 1.8T, ABS only (no ESP or ASR)

    Any ideas what could be wrong?

    Any help appreciated

  2. Remove Advertisements
    VW Passat Forum
    Advertisements
     

  3. #2
    Neutral
    Join Date
    Aug 2006
    Posts
    11
    PS: I dont know what coding the previous ECU had (wasnt able to connect to it at all), this new ECU's coding is following:

    Vag Number: 8E0 614 111 B
    Component: ABS/EDS 5.3 FRONT D00
    Soft. Coding: 0273004283
    Workshop #: BB 24332

    Could anyone please check if it's correct coding for ABS only, no 4motion?

    Thank you

  4. #3
    5th Gear
    Join Date
    Mar 2003
    Location
    Louisville, KY
    Posts
    6,172
    ABS ECU? The ECU is the Engine Control Unit. The ABS controller is the computer that attached to the ABS hydrolic unit. I'll assume we're talking about the ABS controller & not the ECU.

    If the problem is the ABS system's coding, this might help, maybe... http://en.openobd.org/vw/passat_3b.htm

  5. #4
    Neutral
    Join Date
    Aug 2006
    Posts
    11
    Hello, thank you for your answer.
    I think that ECU means Electronic Control Unit.

    The link you posted is for Bosch 5.7, mine is Bosch 5.3

  6. #5
    2nd Gear
    Join Date
    Apr 2003
    Location
    Enola, Pa
    Posts
    662
    Quote Originally Posted by makli View Post
    PS: I dont know what coding the previous ECU had (wasnt able to connect to it at all), this new ECU's coding is following:

    Vag Number: 8E0 614 111 B
    Component: ABS/EDS 5.3 FRONT D00
    Soft. Coding: 0273004283
    Workshop #: BB 24332

    Could anyone please check if it's correct coding for ABS only, no 4motion?

    Thank you
    I have a '99 B5 1.8T ABS only also. Here are my codes.

    Control Module Part Number: 8E0 614 111 B

    Component and/or Version: ABS/EDS 5.3 FRONT D00

    Software Coding: 0273004283

    Work Shop Code: BB 24332


    Which appear to be the same as yours. Is the part # on the ABS pump unit the same for yours and the one the replacement part came from? I understand these are not universal replacement parts.

    Check this thread

  7. #6
    Neutral
    Join Date
    Aug 2006
    Posts
    11
    Hello silberwagen,
    thank you for posting your coding. The new unit is the same part # as the old one.

    According to the VAG Info System, the most likely reasons for this problems are
    - faulty wiring harness (ABS to CAN-bus)
    - the new unit also faulty.

    I will probably take the car to a garage tomorrow and will ask them to check the wiring.

  8. #7
    Neutral
    Join Date
    Aug 2006
    Posts
    11
    Hello silberwagen,

    I have one more question: Does your car have a K-CAN Gateway (CAN-bus)?

    Thank you

  9. #8
    1st Gear
    Join Date
    Aug 2003
    Location
    Waterloo, Iowa
    Posts
    302
    I have the identical coding on my ABS Controller. I bought a used one from a salvage lot in Jersey and it fixed the problem. (Identical part numbers). ($150 or so plus ship)

    Considering the failure rate of these things, is it possible the used one you bought was available because it was already broken?

  10. #9
    Neutral
    Join Date
    Aug 2006
    Posts
    11
    Hello,
    yes, it is possible that the new unit is faulty too, but before I get another one I would like to be sure that it just doesn't come from a car without CAN-bus and needs to be recoded for my car.

  11. #10
    2nd Gear
    Join Date
    Apr 2003
    Location
    Enola, Pa
    Posts
    662
    Quote Originally Posted by makli View Post
    Hello silberwagen,

    I have one more question: Does your car have a K-CAN Gateway (CAN-bus)?

    Thank you
    I'm not sure about this, how can I check ??

  12. #11
    Neutral
    Join Date
    Aug 2006
    Posts
    11
    In VAG-COM:
    Click 'Select Control Module' and then select '19 - CAN Gateway'.
    If it connects to this control unit, then you have it

  13. #12
    1st Gear
    Join Date
    Sep 2006
    Location
    Rio de Janeiro, Brazil
    Age
    32
    Posts
    423
    I´ve seen a lot of people on e-Bay offering to fix damaged ABS modules specially for VW Passat, maybe it´s more interesting than getting and older (and probably busted) and used unit.

    There you go: http://cgi.ebay.com/ebaymotors/AUDI-...QQcmdZViewItem

  14. #13
    Neutral
    Join Date
    Aug 2006
    Posts
    11
    Hello VitorBart,
    I know that it might be possible to repair it, but the problem is that I sent my previous module to some company and they returned it and said repair was not possible. It is also likely that they have damaged the unit so no one other will be able to fix it.

    If this "new" salvaged unit turns out to be faulty I will probably try to get one with ASR instead of current ABS/EDS.

  15. #14
    Neutral
    Join Date
    Aug 2006
    Posts
    11
    Problem solved. The unit was from a car which didnt have CAN-bus. It was necessary to recode CAN gateway (to disable ABS and then enable it again).

  16. #15
    Neutral
    Join Date
    Mar 2009
    Location
    SaoPaulo, Brazil
    Posts
    12

    Question ABS trouble

    Hello, my 99' passat 1.8t ABS Only having the same problem. I replaced the Control Module with the same Bosch PN and no comunication at all. When I disconnect my ABS module, I can connect to everything. Also checked that my car don´t have CAN-BUS. I send the replaced unit to someone that repaired it. Even as, no solution. Perhaps the replaced unit was coded as WITH CAN-BUS. How can I recode the replaced unit as WITHOUT CAN-BUS, because when it connected I can´t comunicate anything? I´m desperate. Thanks you any help!

  17. #16
    Neutral
    Join Date
    Jun 2012
    Location
    denmark
    Posts
    12
    Quote Originally Posted by vagbestech View Post
    Hello, my 99' passat 1.8t ABS Only having the same problem. I replaced the Control Module with the same Bosch PN and no comunication at all. When I disconnect my ABS module, I can connect to everything. Also checked that my car don´t have CAN-BUS. I send the replaced unit to someone that repaired it. Even as, no solution. Perhaps the replaced unit was coded as WITH CAN-BUS. How can I recode the replaced unit as WITHOUT CAN-BUS, because when it connected I can´t comunicate anything? I´m desperate. Thanks you any help!
    Hi. Have you solved your problem ? Because i have the same problem, and without can bus

  18. #17
    3rd Gear
    Join Date
    Mar 2011
    Location
    Columbia, SC/Atlanta
    Posts
    1,075
    Makli,

    Did you have BRAKE light on before you installed the new module?

  19. Remove Advertisements
    VW Passat Forum
    Advertisements
     

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2